Sign in to follow this  
Followers 0
Dean

Our New Logo

1 post in this topic

If you've been around from the beginning you would've seen the changes over the last 17+ years. But for those who have only been around the last couple of years here is some brief history of the site and the logo which have come and gone.

The Club was formed by the amalgamation of the Polo GT/Coupe S Owners Club and the Polo Coupe Owners Club back in 2000.
The original Club Polo "forum", based on Yahoo e-groups. Technically the Polo-l group came first, but this was the first one to get a sizeable volume of traffic. And surprisingly the full archive is still there!

The story is, this was a group for Polo GT owners originally. Keith Lee (who started the Polo GT OC) signed up and linked it to his website (polo-gt.co.uk), then the Polo GT OC joined the Polo Coupe Owners Club (started my Nick Goodyear) and this e-group became a meeting place for both of them.
 

Back in the day (2000-2002) it used to be a wicked place to get information. Then Porka.net started up and effectively made it obselete. Forum software was better than the primitive Yahoo e-groups so it didn't take long for everyone to move across. But there's still some interesting archive material on there if anyone fancies a flick through. A few old pictures too. Quite nice to know it's still about!
 

Porka.net was full of guys with new Polos (mostly mk4s at the time) until the pre-94 owners came across from the e-group. The members started using both sites so they joined to form Club Polo in early 2002. Originally the Club Polo site (a modified version of the Polo GT OC site) linked through to a CP branded Porka.net, then the two sites merged completely.

Check the Wayback Machine website if you're interested - there are some early versions of polo-gt.co.uk archived on that site, but they don't work very well.


1999? - Porka.net

porkaflyer.jpg~original.jpg

 

Early 2000's - Porka.net

CPLOGO2002.png

 

2003 Onwards - www.polo-gt.co.uk

logo.jpg

 

2006 Onwards - www.clubpolo.co.uk

logo.gif

 

2007 Onwards - www.clubpolo.co.uk (This is how I remember the logo when I joined)

mainlogo.gif

 

Middle of 2013 www.clubpolo.co.uk

FrontPage.png

 

2016 - 2017 - www.clubpolo.co.uk
CPLOGO2016.png

 

 

Which brings us to the year 2017!

Our new logo for 2017 - Present

sharer.png
I'm going to slowly start rebranding all the social media accounts and forums to reflect the new logo, we hope you love the new design. Our plan is to sell all our old stock and start a merchandise store with loads of clothing, accessories, etc.

We felt the previous logo was a little dated to say the least and with a new generation coming to our community we want them to look at our logo and be drawn to it, something that looks cool on t-shirts and hoodies!

I hope you've enjoyed this little history lesson and a trip down memory lane.

- Have fun in the forums!

 

5 people like this

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • Jake
      By Jake
      It's that time again, we're going to put together a 2017 Clubpolo calendar featuring your cars! 
      Post your photos along with the month you think they best suit. The 11 with the highest number of likes get the spots! with number 12 a staff pick.
       
       
      I'll start the ball rolling with Eric.
      September / October
       

      @erixtar1992
    • kyle_h95
      By kyle_h95
      hi guys!
      so I bought a polo 6n2 (X reg with 78k miles) couple months back, it was a non runner, seller told me all it needed was a TPS (throttle position sensor)
      so I took it away for near enough £500
      so I trailered it home, ordered up a throttle position sensor, and carried on about fitting it, only then did I realise I needed to take the steering column off, but couldn't get the anti tamper bolts off, so ended up taking the dash off.
      adventually the new tps was fitted, but to no avail. so I got a friend down with his vag com to have a look for me, he told me I had a wiring fault, couple guys on here told me it could be a faulty throttle body, or a fried ecu.
      ended up going for a second hand working throttle body, but once again, to no avail.
      turns out it was a ecu, and an unrepairable one at that. so after paying just over £300 just to get the thing throttling again, I was a happy chappy, next was the MOT, which was a nightmare and ended up costing over another £100 (fitted all new parts my self). Once again, happy as larry, finally on the roads!
      so I gave it a small service just to last me till the end of the month when I got paid.
      so, the car took me to work and back for one day, went out that evening with a mate, get a few miles down the road, and notice the car was running REALLY rough....
      Took the car home, borrowed a friends compression tester as I knew the plugs and leads were fine (new), at which point I found out
      CYL 1- 7BAR
      CYL 2- 8BAR
      CYL 3- 7 BAR
      CYL 4- Nothing.
      once again, gutted.
      so stripped it down to find the cam follower missing, and my camshaft scored to F****!
      looked at pistons there fine, no excessive play or damage.
      Turns out its cheaper to just get an engine for her!
      so anyway, after spending too much on the car in the first place, I now need a new engine.
      so I've got a couple questions for you guys!
      1- Has anyone on here got a 1.0mpi AUC engine for sale?
      2- Can I leave the gearbox in when taking the engine out, or does is need to come with it?
      Ever felt like you've been done over?
      p-s- sorry about the long story! lol