Jump to content
Notice to Hotmail/Gmail & BT Internet users - Please check your SPAM/JUNK folders for our emails. Please add our email as a contact to your email account.
rolo_the_polo

Chugging / Dead Acceleration

Recommended Posts

rolo_the_polo

Long post, sorry... but a problem i can’t get my head around..! 

 

So I am having trouble with the engine running smoothly and driving fine but then after stopping at lights accelleration will be nothing other than a chug at best. 

 

First thought of mine and 1st AA man was fuel starvation (it ran out of fuel a week or so before, which is how I found out it reading half a tank actually means empty..! So thought it might be crap come up from the bottom ofthe tank) So change the fuel filter and it runs smoothly again ... for about 10 miles and the same thing happens again at another set of lights. 

 

Second AA man swaps the king HT lead around and with a bit of WD40 off it goes again smooth as anything. So get a new set of HT leads and happy motoring for another 10 or so miles when it happens again. This time me and AA man 3 are flummoxed.

 

And that’s where I am now - i still think fuel starvation so a carb clean / tank clean but keen to see if any of you have any ideas.

Share this post


Link to post
Share on other sites
steveo3002

is it the 83 as per your profile?

 

should be a clear plastc filter...50p or so , cut the one on the car open and inspect it over a sheet of clean paper , should be easy to see if its full of crap or still clean, regardless theyre cheap to have a few laying around

 

another thought...is the breather clear on the fuel tank clear?  open the filler cap and see if theres a hiss , or will it run ok with the cap off (temporarily)

 

if its the 83 then bad points can cause problems , they need setting up right and use good quality parts

Share this post


Link to post
Share on other sites
caretakerplus

Check the fuel filler neck from where you put the pump nozzle to the tank itself - they do sometimes allow water to get into the tank.

 

Regards

Share this post


Link to post
Share on other sites
rolo_the_polo
23 minutes ago, steveo3002 said:

is it the 83 as per your profile?

 

should be a clear plastc filter...50p or so , cut the one on the car open and inspect it over a sheet of clean paper , should be easy to see if its full of crap or still clean, regardless theyre cheap to have a few laying around

 

another thought...is the breather clear on the fuel tank clear?  open the filler cap and see if theres a hiss , or will it run ok with the cap off (temporarily)

 

if its the 83 then bad points can cause problems , they need setting up right and use good quality parts

Cheers for this. Yeah 83. 

 

Fuel filter has only been on about 20 miles - still looks clean. I do get a hiss or an air release when i turn the cap, yeah. 

 

I did think maybe points as another step too seeing as the HT swap seemed to solve things so will try that too. 

 

Thanks! 

Share this post


Link to post
Share on other sites
steveo3002

another tip...if it dies again look in the filter to see if its got petrol inside

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use Privacy Policy Guidelines